cancel
Showing results for 
Search instead for 
Did you mean: 

Webhooks not working in sandbox

Options
ACLayer
Contributor
Posted on

Hi community,

 

I created a REST API app in sandbox, and set up a webhook in the developer dashboard (with all events selected).

I then logged into a sandbox account and created an invoice in the UI, but an "INVOICING.INVOICE.CREATED" event was never sent to my webhook listener.

I tried other operations but no webhook events.

 

My question is: can sandbox events originated from the UI not trigger webhooks? is this by design, or am I missing something?

 

Thanks!

 

1 REPLY 1

Webhooks not working in sandbox

Options
kstep2
New Community Member

I am having a similar issue. 

The merchant ID for my sandbox account is: FWGRGBSB6SWJQ

I am trying to walk through various test scenarios using sandbox accounts so that I can get our webhook system setup correctly. I am unable to get any webhooks to send to my sandbox PayPal app. 

Here are the steps that cause the issue:
1. Create a new sandbox app.
2. Select desired permissions for the app.
3. Enter ngrok URL as webhook URL and select all events (I have also tested just selecting singular events).
4. Go to my sandbox accounts and confirm the account I am using has access to the newly created app.
5. Create a test purchase within the sandbox account.

I have been testing this for the past couple of days and I have not received ANY webhooks. I do not think it is an issue on my end.

Note: I have tested the webhook simulator with the same ngrok URL and that has worked fine.

Thanks in advance!

Haven't Found your Answer?

It happens. Hit the "Login to Ask the community" button to create a question for the PayPal community.