cancel
Showing results for 
Search instead for 
Did you mean: 

REST API app secret key not displaying in sandbox mode

Contributor

REST API app secret key not displaying in sandbox mode

I have been unable to retrieve the secret key for my REST API app in SANDBOX mode, although it is being displayed when in LIVE mode. I've tested with multiple browsers and on multiple terminals, and the SHOW button is just not responding in sandbox mode. I have also tried creating a new app, but the same issue persists with that too.

 

Has anyone else faced this issue? Could I have missed some step or requirement? The first app is an old one, created more than a year ago, and I was able to retrieve the secret key and test it sandbox mode then, and it is still working now.

 

Thank you for your kind attention.

7 REPLIES 7
Contributor

Re: REST API app secret key not displaying in sandbox mode

I am having the same problem. It is too buggy. Moreover, unable to delete app too. Giving correct name still rejecting. Sandbox is too buggy and I am afraid if we would be able to implement PayPal in our system or not.

 

sandbox.JPG

Contributor

Re: REST API app secret key not displaying in sandbox mode

I'm having the same problem, would like to be informed if there is a fix/workaround. I'm testing different invoicing solutions and this has rendered my testing of Paypal unsuccessful.


@Qompute wrote:

I have been unable to retrieve the secret key for my REST API app in SANDBOX mode, although it is being displayed when in LIVE mode. I've tested with multiple browsers and on multiple terminals, and the SHOW button is just not responding in sandbox mode. I have also tried creating a new app, but the same issue persists with that too.

 

Has anyone else faced this issue? Could I have missed some step or requirement? The first app is an old one, created more than a year ago, and I was able to retrieve the secret key and test it sandbox mode then, and it is still working now.

 

Thank you for your kind attention.


 

Contributor

Re: REST API app secret key not displaying in sandbox mode

Hi! Same problem here, but i have found one solution.

Inspect with developer console the show button element. A few lines below there's a div like this:

<div id="credentials-table-sb" aria-labelledby="show-secret" class="display-none" data-length="1">

 

Simply remove the display-none class and the secret will shows.

 

Regards!

Contributor

Re: REST API app secret key not displaying in sandbox mode

Thanks man! this really helped, though now I get an error on the app due to permissions hahaha Moving on to debug that.

Contributor

Re: REST API app secret key not displaying in sandbox mode

This workaround was successful...come on paypal! lol

Thanks for your help!!!

Contributor

Re: REST API app secret key not displaying in sandbox mode

Contacted MTS Support, and they acknowledged & rectified they issue.
Contributor

Re: REST API app secret key not displaying in sandbox mode

Yeah, day before I have checked and it was working. Sorry, was busy so forgot to update here.