can't remove trusted device or change password

New Community Member

I'm having problems with trying to remove a trusted device from the "Manage your logins" page. When i click remove, all i get is a message saying "We're sorry, something seems to have gone wrong. Please try again." I cleared my cache, history etc and tried afain but still happened. I am also facing the same problem when trying to change my password. Sometimes it will let me type in the password but when i press change password, nothing happens. Other times it will not open the page and i am met with the same "We're sorry, something seems to have gone wrong. Please try again." Please help, thank you.

Login to Me Too


Hello @MrWayne1


Welcome to the PayPal Community! I'm sorry to hear you've run into some issues removing a trusted device. Have you tried making that adjustment from another device entirely? It sounds like the password issue and the issue removing the trusted device may potentially both be issues related with your browser. 


If you're still running into issues after trying another device, you may want to reach out to our Customer Support teams for assistance. 


Good luck!


 - Jon K

If you find this or any other post was helpful, make our community better by giving kudos or accepting it as a solution.
Login to Me Too

Haven't Found your Answer?

It happens. Hit the "Login to Ask the community" button to create a question for the PayPal community.