cancel
Showing results for 
Search instead for 
Did you mean: 

Some live webhook not firing at all

Contributor

Some live webhook not firing at all

I'm having issues where live webhooks I expect aren't firing based on events I observed while developing in sandbox mode. Critical ones missing are events for when agreement recurring payment fails, agreement suspension, etc. to name a few. The biggest problem is that we are unable to follow up on refunds, obviously since Paypal doesn't let us know. Does anyone else have issues with live webhooks? I've already contacted support, and they have been telling me they are investigating the issue for more than a few weeks.

 

I'm using the agreement rest API, and my webhook configuration is correct on the dev dashboard, as they work as expected in sandbox with the same configs.

4 REPLIES 4
Volunteer Advisor

Re: Some live webhook not firing at all

Are you sure you subscribed to each of the events you're wanting? If it's all working in the sandbox it sounds like you did that there, but did you follow the same procedure for your live account as well?

Have you used the simulator tools to see if your listeners are working as expected? Have you checked your web server logs for failures when the listener scripts are hit?

Angell EYE - www.angelleye.com
PayPal Partner and Certified Developer - Kudos are Greatly Appreciated!
Contributor

Re: Some live webhook not firing at all

Hey angelleye, all events are subscribed to, and the webhooks are all working. There is certainly something wrong with production webhooks for their rest services. I've filed support tickets multiple times, and they are still looking into it.

 

Volunteer Advisor

Re: Some live webhook not firing at all

Okay, please keep us updated here. I'd like to know the details as I plan to be working a lot more with Webhooks in the near future. Thanks!
Angell EYE - www.angelleye.com
PayPal Partner and Certified Developer - Kudos are Greatly Appreciated!
Highlighted
Contributor

Re: Some live webhook not firing at all

It turned out that missing rest API webhooks are just that; the rest service is simply not firing them. The rest service does not seem production ready at all. You have to use NVP webhooks and IPNs to supplement. I'd advise using IPN if possible, since it seems mature.