cancel
Showing results for 
Search instead for 
Did you mean: 

HELP! update_client_config_error in production!

Options
Go to solution
silhouetteameri
Contributor
Posted on

We are using smart buttons to start billing agreements for recurring payments. Suddenly, these are not working today, as there is a 403 error returned by PayPal when clicking on the button. It works in sandbox mode, but only the production is broken.

 

The following URL returns a 403 error upon clicking the button: https://www.paypal.com/smart/api/billagmt/subscriptions/I-K1EJ6HJLCMCC/cartid (I can provide other examples for different agreements we have set up)

Following this error, it throws the following JavaScript error: 

update_client_config_error {err: "Error: Api: /smart/api/billagmt/subscriptions/I-K1…intent=capture&commit=true&vault=true:1112:18916)", timestamp: "1595883152358", referer: "www.paypal.com", sdkCorrelationID: "c73abb55cb789", sessionID: "af38cf692f_mja6nti6mju", …}

Help!!! We didn't change anything in our configuration that should be causing this.

1 ACCEPTED SOLUTION

Accepted Solutions
Solved

HELP! update_client_config_error in production!

Options
Go to solution
silhouetteameri
Contributor

After further review, it seems there is some local configuration issue causing the problem. If I make the request from a different location, browser, or in Incognito mode, it works fine. Closing this for now...

View solution in original post

5 REPLIES 5

HELP! update_client_config_error in production!

Options
Go to solution
silhouetteameri
Contributor

FYI, I've confirmed that our client ID is still valid by comparing the client ID we are using in production to the client ID found when I sign into PayPal's "Developer Applications" area, so I can confirm that no one has generated a new client ID.

Solved

HELP! update_client_config_error in production!

Options
Go to solution
silhouetteameri
Contributor

After further review, it seems there is some local configuration issue causing the problem. If I make the request from a different location, browser, or in Incognito mode, it works fine. Closing this for now...

HELP! update_client_config_error in production!

Options
Go to solution
Whack_Club
Contributor

@silhouetteameri can you please provide details on the "local settings" you're referring to? I followed your suggestion and found that the code works as expected when used in incognito mode.

HELP! update_client_config_error in production!

Options
Go to solution
jjorosa
Contributor

I'm having the same problem. 

 

Works OK in sandbox, but not in production.

 

Now, it seems random. First I thought that was a Chrome related issue, because on Safari was working OK. Next day, it worked OK using any browser. 

 

Today, it stopped working using both browsers. An hour later, it worked OK in Chrome and not in Safari. And now, it's working OK using both browsers.

 

However, I noticed the problem because I lost 3 customers that got the collapsing PayPal login window.

 

I've sent a support message with the details. But no answer so far.

 

I'll keep checking.

 

Regards.

 

HELP! update_client_config_error in production!

Options
Go to solution
Whack_Club
Contributor

We're experiencing the exact same issue. It is as intermittent as described by a previous poster.

A reply by PayPal to this question in our message center says that we should call a 0800 number and speak to the Product and Site Support Department. All of the selected options lead to an automated system though.

 

Please post here if you find a solution.

Haven't Found your Answer?

It happens. Hit the "Login to Ask the community" button to create a question for the PayPal community.