cancel
Showing results for 
Search instead for 
Did you mean: 

Possible phishing email

SOLVED
New Community Member

Possible phishing email

Did Paypal send me an email insisting I have you re-configure my browser? I have received it twice, and it says I have until the end of June.

Tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
Anonymous_User
Not applicable

Re: Possible phishing email

I'm fairly sure that email was not a spoof.   There's a web wide security upgrade in process and many sites have already completed the updates behind the scenes.  Bottom line, for most of us, the only thing you have to do is ensure your web browser is up to date, else when surfing the net, it's possible that you may not be able to view some site.   PayPal has updated their site and they want to make sure that when you go there you can view it.

 

Here's some details gathered from the internet that may help you out.

 

Many web based services including PayPal are or have been updating their site security Transport Layer Security – or TLS – from TLS 1.0 to TLS 1.1. The Transport Layer Security (TLS) is a cryptographic protocol used to establish a secure communications channel between two systems.   It is used to authenticate one or both systems, and protect the confidentiality and integrity of information that passes between systems including things as email, Internet faxing, and other data transfers.   To ensure the security of your personal information, your web browser also needs to be compatible with the new protocol. Browsers that don’t support TLS v1.1 or v1.2 will not be able to view any site that has upgraded to TLS 1.1.

The following browsers support the security changes and no action is required on your part:

    Internet Explorer 11 (Desktop & Mobile)
    Internet Explorer 8,9,10 (Desktop – Compatible but not enabled by default)
    Firefox 27 and higher
    Google Chrome 38 and higher
    Google Android 5.0 and higher
    Safari 7 on OSX 10.9 (Mavericks) Desktop and higher
    Safari 5 on iOS 5 Mobile and higher
    Edge

The following operating systems are not compatible with TLS 1.1 or higher and it's recommended that you upgrade your operating system to a supported system:

    Windows XP
    Windows Vista
    Server 2008
    Server 2003


Notes:
* If you're currently using Internet Explorer 7 or earlier – You must upgrade your browser
* If you're currently using Google Chrome – You must have have Windows 7 or a newer operating system
* If you're currently using Firefox version 26 or earlier – You must have Windows XP Service Pack 2 or newer
* If you're currently using Safari – versions older than 7 on OSX 1.9 (Mavericks) – TLS 1.1 and TLS 1.2 are not supported, so you must use Google Chrome for MAC

Tags (1)
1 REPLY
Anonymous_User
Not applicable

Re: Possible phishing email

I'm fairly sure that email was not a spoof.   There's a web wide security upgrade in process and many sites have already completed the updates behind the scenes.  Bottom line, for most of us, the only thing you have to do is ensure your web browser is up to date, else when surfing the net, it's possible that you may not be able to view some site.   PayPal has updated their site and they want to make sure that when you go there you can view it.

 

Here's some details gathered from the internet that may help you out.

 

Many web based services including PayPal are or have been updating their site security Transport Layer Security – or TLS – from TLS 1.0 to TLS 1.1. The Transport Layer Security (TLS) is a cryptographic protocol used to establish a secure communications channel between two systems.   It is used to authenticate one or both systems, and protect the confidentiality and integrity of information that passes between systems including things as email, Internet faxing, and other data transfers.   To ensure the security of your personal information, your web browser also needs to be compatible with the new protocol. Browsers that don’t support TLS v1.1 or v1.2 will not be able to view any site that has upgraded to TLS 1.1.

The following browsers support the security changes and no action is required on your part:

    Internet Explorer 11 (Desktop & Mobile)
    Internet Explorer 8,9,10 (Desktop – Compatible but not enabled by default)
    Firefox 27 and higher
    Google Chrome 38 and higher
    Google Android 5.0 and higher
    Safari 7 on OSX 10.9 (Mavericks) Desktop and higher
    Safari 5 on iOS 5 Mobile and higher
    Edge

The following operating systems are not compatible with TLS 1.1 or higher and it's recommended that you upgrade your operating system to a supported system:

    Windows XP
    Windows Vista
    Server 2008
    Server 2003


Notes:
* If you're currently using Internet Explorer 7 or earlier – You must upgrade your browser
* If you're currently using Google Chrome – You must have have Windows 7 or a newer operating system
* If you're currently using Firefox version 26 or earlier – You must have Windows XP Service Pack 2 or newer
* If you're currently using Safari – versions older than 7 on OSX 1.9 (Mavericks) – TLS 1.1 and TLS 1.2 are not supported, so you must use Google Chrome for MAC

Tags (1)