cancel
Showing results for 
Search instead for 
Did you mean: 

PPP Loan site broken?

Highlighted
Contributor

PPP Loan site broken?

Hi all, I am trying to apply for PPP Loan. I go to all the steps, upload my information and files but nothing happens. It won't move forward. And there is no submit or anything. I have done this several times and I am back to square one. Please help

2 REPLIES 2
Highlighted
PayPal Employee

Re: PPP Loan site broken?

Hi @mojdeh_m , 

I'm sorry you're experiencing difficulties.  I just verified the site is not broken and is able to accept applications.  You may find it helpful to clear cache and cookies or try a different browser.

Highlighted
Contributor

Re: PPP Loan site broken?

Thank you for your reply. Believe me I am not a novice user to webapps. I designed these (still do) for ages. I am sure something is wrong here. I keep going through the steps, upload all the documents, see the checkmark but no final "forward" or "continue" etc --- then all of a sudden the first check mark says start here! If you click it, you either are stopped there or you are back to the beginning. I have gone back and tried to login. Then it says "no summary and no actions" -- how could that be when I have uploaded the files. In the meantime, Paypal sends me a warning that since they have not heard back from me in a while, they will withdraw my information!! I replied and yet no answer and no help.
I have used a different browser and still the same problem. Unfortunately, after waiting and waiting, when the customer service contacted me they sent me the generic information - but my issue is not a general issue. It is a technical one. I am running out of time. Not only this is a timely manner since the money will run out but also I am scheduled for a surgery on Tuesday so unless I take care of this today or tomorrow the latest - I won't be able to do much after the surgery for a few days - at least. is there anyway you can help?

Here are two of the screenshots. Do you see that I have done the steps and yet I have a Get Started -- it appears after all the steps are done! At first it is a checkmark too. 
Do you see that I see no summary?

Thanks

  

001_AfterUploads.png