cancel
Showing results for 
Search instead for 
Did you mean: 

Paypal Here - New minimum system requirements for Android?

Highlighted
Contributor

Paypal Here - New minimum system requirements for Android?

So today I have a customer come into my brick-and-mortar store, I try logging into Paypal Here on my Android phone to process the payment, and the login fails, saying that my connection is insecure, to please try another internet connection.  After speaking with someone on the phone at paypal, it was determined that the most likely problem is that I needed to update my Paypal Here app.

 

Up until the most recent update (version 3.1), the minimum requirements were simply Android 4.0.3 and nothing else.  My phone is 4.0.4 so I've never had any problems.  Well, the newest version released within the past month is Paypal Here 3.1.something, and it requires Android 4.1 and up.  In the Google Play Store, it told me that my device did not support the current Paypal Here version.

 

So I'm thinking, ok, no problem, I'll just update my phone's OS.  So I updated to Android 4.1.2.  Then I go into Google Play and YES, now I can download and install the app.  So I did that.  I open the app, try to log in, and this time it let me log in without the insecure warning, but a separate message pops up saying something like "Quick Security Check", at which time it opens my web browser with a message saying that my browser is not TLS 1.2 compliant.  It gives a link to a TLS compliance test, which I click on that, and the test PASSES.  But when I close out Chrome, the app just goes back to a login screen, so I can never get logged in.  I have confirmed that my browser is indeed 1.2 compliant, but what relevance is that to the stand-alone app?

 

This is BEYOND FRUSTRATING.  Can somebody here tell me the official system requirements for Paypal Here?  Per paypal's official help center, you're only supposed to need 4.0.3, and per the app store, the newest version is supposed to run on 4.1 and up.  I meet these requirements and still no dice.  It would be nice if Paypal would update its help center info to let us know what we need because I'm not about to go out and spend $100 or more on a new tablet only to have it not work either.  The phone rep I spoke to suggested Android 6 and up.  Ok, that's great and all, then why does the app say it'll run on 4.1?

3 REPLIES 3
New Community Member

Re: Paypal Here - New minimum system requirements for Android?

I'm having this exact same issue. Caught in a loop with the security check that just takes me to a Paypal page explaining how to check my browser (which my browser PASSES). Can't log into PayPal Here at all with this issue. Have you managed to resolve it?

Contributor

Re: Paypal Here - New minimum system requirements for Android?

Have you gotten any info on this problem?  I just recently got PayPal here and ordered an amazon fire tablet only to find out that wasn't compatible.  I then checked PayPal's website to see what devices ARE compatible and saw that the galaxy tab 2 7" is so I ordered that and received it today.  Now I install PayPal here and have the same problem as you!  I checked and I am running Android 4.2.2.  I am getting so angry that I may just say **bleep** it and use another payment management device.  This shouldn't be this hard.

Contributor

Re: Paypal Here - New minimum system requirements for Android?

Is there any further update to this issue?

 

Thanks!

Jake